$re = '/\s*(\.+|[[:punct:]])(?<!\b[\'’]\b)\s*/m';
$str = 'I want: spaces around all these marks;:!?.but i didn’t want it there in didn\'t';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;