#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*"
Local $sString = "I want: spaces around all these marks;:!?.but i didn’t want it there in didn't"
Local $sSubst = " \1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)