import Foundation
let pattern = #"\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I want: spaces around all these marks;:!?.but i didn’t want it there in didn't"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)