re = /\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*/m
str = 'I want: spaces around all these marks;:!?.but i didn’t want it there in didn\'t'
subst = ' \\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result