#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$field\.setOrderNumber\((\d*)\)"
Local $sString = "rule "CollectorCar - System Territory - Field Assemble Rule"" & @CRLF & _
" " & @CRLF & _
" when" & @CRLF & _
" $section : Section(key == "ccGarageLocation")" & @CRLF & _
" $field : Field(key == "territory" && resourceType =="garagingAddress")" & @CRLF & _
" then" & @CRLF & _
" $field.setOrderNumber(11);" & @CRLF & _
" $section.addField($field);" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")