$re = '/\$field\.setOrderNumber\((\d*)\)/';
$str = 'rule "CollectorCar - System Territory - Field Assemble Rule"
when
$section : Section(key == "ccGarageLocation")
$field : Field(key == "territory" && resourceType =="garagingAddress")
then
$field.setOrderNumber(11);
$section.addField($field);
end';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);