re = /\$field\.setOrderNumber\((\d*)\)/
str = 'rule "CollectorCar - System Territory - Field Assemble Rule"
when
$section : Section(key == "ccGarageLocation")
$field : Field(key == "territory" && resourceType =="garagingAddress")
then
$field.setOrderNumber(11);
$section.addField($field);
end'
# Print the match result
str.match(re) do |match|
puts match.to_s
end