package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$field\.setOrderNumber\((\d*)\)`)
var str = `rule "CollectorCar - System Territory - Field Assemble Rule"
when
$section : Section(key == "ccGarageLocation")
$field : Field(key == "territory" && resourceType =="garagingAddress")
then
$field.setOrderNumber(11);
$section.addField($field);
end`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}