const regex = /\$field\.setOrderNumber\((\d*)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$field\\.setOrderNumber\\((\\d*)\\)', '')
const str = `rule "CollectorCar - System Territory - Field Assemble Rule"
when
\$section : Section(key == "ccGarageLocation")
\$field : Field(key == "territory" && resourceType =="garagingAddress")
then
\$field.setOrderNumber(11);
\$section.addField(\$field);
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}