// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$field\.setOrderNumber\((\d*)\)").unwrap();
let string = "rule \"CollectorCar - System Territory - Field Assemble Rule\"
when
$section : Section(key == \"ccGarageLocation\")
$field : Field(key == \"territory\" && resourceType ==\"garagingAddress\")
then
$field.setOrderNumber(11);
$section.addField($field);
end";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}