import Foundation
let pattern = #"\$field\.setOrderNumber\((\d*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
rule "CollectorCar - System Territory - Field Assemble Rule"
when
$section : Section(key == "ccGarageLocation")
$field : Field(key == "territory" && resourceType =="garagingAddress")
then
$field.setOrderNumber(11);
$section.addField($field);
end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}