using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$?{(?:[^}\$?{]+|(?R))*+}";
string input = @"~${() => props.pages().map(page => html`<li class=""page-item${() => page==props.currentPage() ? ' active' : ''}""><a class=""page-link"" href=""/${props.view}/?p=${page}"" onclick=""${(e) => {e.preventDefault(); props.callback(page);}}"">${page}</a></li>`)}~";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}