re = /\$?{(?:[^}\$?{]+|(?R))*+}/
str = '~${() => props.pages().map(page => html`<li class="page-item${() => page==props.currentPage() ? \' active\' : \'\'}"><a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a></li>`)}~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end