import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$?\\{(?:[^\\}\\$?\\{]+|(?R))*+\\}";
final String string = "~${() => props.pages().map(page => html`<li class=\"page-item${() => page==props.currentPage() ? ' active' : ''}\"><a class=\"page-link\" href=\"/${props.view}/?p=${page}\" onclick=\"${(e) => {e.preventDefault(); props.callback(page);}}\">${page}</a></li>`)}~";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}