package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$?{(?:[^}\$?{]+|(?R))*+}`)
var str = `~${() => props.pages().map(page => html\`<li class="page-item${() => page==props.currentPage() ? ' active' : ''}"><a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a></li>\`)}~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}