// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$?{(?:[^}\$?{]+|(?R))*+}").unwrap();
let string = "~${() => props.pages().map(page => html`<li class=\"page-item${() => page==props.currentPage() ? ' active' : ''}\"><a class=\"page-link\" href=\"/${props.view}/?p=${page}\" onclick=\"${(e) => {e.preventDefault(); props.callback(page);}}\">${page}</a></li>`)}~";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}