const regex = /\$?{(?:[^}\$?{]+|(?R))*+}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$?{(?:[^}\\$?{]+|(?R))*+}', 'g')
const str = `~\${() => props.pages().map(page => html\`<li class="page-item\${() => page==props.currentPage() ? ' active' : ''}"><a class="page-link" href="/\${props.view}/?p=\${page}" onclick="\${(e) => {e.preventDefault(); props.callback(page);}}">\${page}</a></li>\`)}~`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}