$re = '/\$?{(?:[^}\$?{]+|(?R))*+}/';
$str = '~${() => props.pages().map(page => html`<li class="page-item${() => page==props.currentPage() ? \' active\' : \'\'}"><a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a></li>`)}~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);