use strict;
my $str = '~${() => props.pages().map(page => html`<li class="page-item${() => page==props.currentPage() ? \' active\' : \'\'}"><a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a></li>`)}~';
my $regex = qr/\$?{(?:[^}\$?{]+|(?R))*+}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}