package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$`)
var str = `00000
zahir
31z44
z38vr
2331
444444
zahir 22
13325`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}