use strict;
my $str = '00000
zahir
31z44
z38vr
2331
444444
zahir 22
13325';
my $regex = qr/^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}