import Foundation
let pattern = #"^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
00000
zahir
31z44
z38vr
2331
444444
zahir 22
13325
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}