const regex = new RegExp('^((\\D*)|(.{0,4})|(.{6,})|(00000)|(\\D+\\d+.*)|(\\d+\\D+.*))$', '')
const str = `00000
zahir
31z44
z38vr
2331
444444
zahir 22
13325`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}