re = /^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$/
str = '00000
zahir
31z44
z38vr
2331
444444
zahir 22
13325'
# Print the match result
str.match(re) do |match|
puts match.to_s
end