import re
regex = re.compile(r"^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$")
test_str = ("00000\n"
"zahir\n"
"31z44\n"
"z38vr\n"
"2331\n"
"444444\n"
"zahir 22\n"
"13325")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")