import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\D*)|(.{0,4})|(.{6,})|(00000)|(\\D+\\d+.*)|(\\d+\\D+.*))$";
final String string = "00000\n"
+ "zahir\n"
+ "31z44\n"
+ "z38vr\n"
+ "2331\n"
+ "444444\n"
+ "zahir 22\n"
+ "13325";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}