# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\n|\\n)(?!$)/<br \/>/g;t' <<< "sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\nsdfhjsdhfsdj\nsdjhfsdklhfksd\nnsdkfhsdkljfsdkl\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl"