use strict;
my $str = 'sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\\nsdfhjsdhfsdj\\nsdjhfsdklhfksd\\nnsdkfhsdkljfsdkl\\\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl';
my $regex = qr/(\n|\\n)(?!$)/p;
my $subst = '<br />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";