#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\n|\\n)(?!$)"
Local $sString = "sdgfsdjkhfsdjif" & @CRLF & _
"sdklfjsdklfjsdkl" & @CRLF & _
"sdkljhsdklfjsdklsdfj" & @CRLF & _
"lsjdfllfksdfsdf\nsjdfklsdfjksdhfsdk" & @CRLF & _
"sdjkfsdjkfhsdlfs" & @CRLF & _
"dfsdjfjsdf" & @CRLF & _
"sdfidklgjsd" & @CRLF & _
"sdfkjfsd" & @CRLF & _
"fdsjfkjsd\nsdfhjsdhfsdj\nsdjhfsdklhfksd\nnsdkfhsdkljfsdkl\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl"
Local $sSubst = "<br />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)