import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n|\\\\n)(?!$)";
final String string = "sdgfsdjkhfsdjif\n"
+ "sdklfjsdklfjsdkl\n"
+ "sdkljhsdklfjsdklsdfj\n"
+ "lsjdfllfksdfsdf\\nsjdfklsdfjksdhfsdk\n"
+ "sdjkfsdjkfhsdlfs\n"
+ "dfsdjfjsdf\n"
+ "sdfidklgjsd\n"
+ "sdfkjfsd\n"
+ "fdsjfkjsd\\nsdfhjsdhfsdj\\nsdjhfsdklhfksd\\nnsdkfhsdkljfsdkl\\\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl";
final String subst = "<br />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}