import Foundation
let pattern = #"(\n|\\n)(?!$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\nsdfhjsdhfsdj\nsdjhfsdklhfksd\nnsdkfhsdkljfsdkl\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)