using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n|\\n)(?!$)";
string substitution = @"<br />";
string input = @"sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\nsdfhjsdhfsdj\nsdjhfsdklhfksd\nnsdkfhsdkljfsdkl\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}