$re = '/(\n|\\\\n)(?!$)/';
$str = 'sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\\nsdfhjsdhfsdj\\nsdjhfsdklhfksd\\nnsdkfhsdkljfsdkl\\\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl';
$subst = "<br />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;