#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(word1|word2|word3)|."
Local $sString = "jsdjsqd word1dsqsqsword2fjsdjsword3sqdq"
Local $sSubst = "P\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)