using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(word1|word2|word3)|.";
string substitution = @"P\1";
string input = @"jsdjsqd word1dsqsqsword2fjsdjsword3sqdq";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}