re = /(word1|word2|word3)|./
str = 'jsdjsqd word1dsqsqsword2fjsdjsword3sqdq'
subst = 'P\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result