import Foundation
let pattern = #"(word1|word2|word3)|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"jsdjsqd word1dsqsqsword2fjsdjsword3sqdq"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"P\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)