package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(word1|word2|word3)|.`)
var str = `jsdjsqd word1dsqsqsword2fjsdjsword3sqdq`
var substitution = "P\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}