// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(word1|word2|word3)|.").unwrap();
let string = "jsdjsqd word1dsqsqsword2fjsdjsword3sqdq";
let substitution = "P\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}