$re = '/(word1|word2|word3)|./s';
$str = 'jsdjsqd word1dsqsqsword2fjsdjsword3sqdq';
$subst = "P\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;