use strict;
my $str = 'jsdjsqd word1dsqsqsword2fjsdjsword3sqdq';
my $regex = qr/(word1|word2|word3)|./sp;
my $subst = 'P\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";