#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$form->AddFields\({(?![^}]+id =>)[^}]+}\);"
Local $sString = "$form->AddFields({" & @CRLF & _
" id => 2048" & @CRLF & _
" type => 'hidden'," & @CRLF & _
" name => 'xyz'," & @CRLF & _
" value => 0," & @CRLF & _
"});" & @CRLF & _
"" & @CRLF & _
"$form->AddFields({" & @CRLF & _
" type => 'hidden'," & @CRLF & _
" name => 'xyz'," & @CRLF & _
" value => 0," & @CRLF & _
"});" & @CRLF & _
"" & @CRLF & _
"$form->AddFields({" & @CRLF & _
" type => 'hidden'," & @CRLF & _
" name => 'xyz'," & @CRLF & _
" id => 1024," & @CRLF & _
" value => 0," & @CRLF & _
"});" & @CRLF & _
"$form->AddFields({" & @CRLF & _
" type => 'hidden'," & @CRLF & _
" name => 'abc'," & @CRLF & _
" value => 10," & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")