$re = '/\$form->AddFields\({(?![^}]+id =>)[^}]+}\);/m';
$str = '$form->AddFields({
id => 2048
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
id => 1024,
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'abc\',
value => 10,
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);