const regex = /\$form->AddFields\({(?![^}]+id =>)[^}]+}\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$form->AddFields\\({(?![^}]+id =>)[^}]+}\\);', 'gm')
const str = `\$form->AddFields({
id => 2048
type => 'hidden',
name => 'xyz',
value => 0,
});
\$form->AddFields({
type => 'hidden',
name => 'xyz',
value => 0,
});
\$form->AddFields({
type => 'hidden',
name => 'xyz',
id => 1024,
value => 0,
});
\$form->AddFields({
type => 'hidden',
name => 'abc',
value => 10,
});`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}