import re
regex = re.compile(r"\$form->AddFields\({(?![^}]+id =>)[^}]+}\);", flags=re.MULTILINE)
test_str = ("$form->AddFields({\n"
" id => 2048\n"
" type => 'hidden',\n"
" name => 'xyz',\n"
" value => 0,\n"
"});\n\n"
"$form->AddFields({\n"
" type => 'hidden',\n"
" name => 'xyz',\n"
" value => 0,\n"
"});\n\n"
"$form->AddFields({\n"
" type => 'hidden',\n"
" name => 'xyz',\n"
" id => 1024,\n"
" value => 0,\n"
"});\n"
"$form->AddFields({\n"
" type => 'hidden',\n"
" name => 'abc',\n"
" value => 10,\n"
"});")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")