re = /\$form->AddFields\({(?![^}]+id =>)[^}]+}\);/m
str = '$form->AddFields({
id => 2048
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
id => 1024,
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'abc\',
value => 10,
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end