import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$form->AddFields\\(\\{(?![^\\}]+id =>)[^\\}]+\\}\\);";
final String string = "$form->AddFields({\n"
+ " id => 2048\n"
+ " type => 'hidden',\n"
+ " name => 'xyz',\n"
+ " value => 0,\n"
+ "});\n\n"
+ "$form->AddFields({\n"
+ " type => 'hidden',\n"
+ " name => 'xyz',\n"
+ " value => 0,\n"
+ "});\n\n"
+ "$form->AddFields({\n"
+ " type => 'hidden',\n"
+ " name => 'xyz',\n"
+ " id => 1024,\n"
+ " value => 0,\n"
+ "});\n"
+ "$form->AddFields({\n"
+ " type => 'hidden',\n"
+ " name => 'abc',\n"
+ " value => 10,\n"
+ "});";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}