#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?![^<]*?>)\b[\w\h]{7,})"
Local $sString = "<html>" & @CRLF & _
" <tabel tags="gohere'>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>detects strings</td>" & @CRLF & _
" <td>" & @CRLF & _
" of a" & @CRLF & _
" length" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" and <b> ignores HTML </b>" & @CRLF & _
" <br />" & @CRLF & _
" formating" & @CRLF & _
" </td>" & @CRLF & _
" <td> this checks for string atleast 7 char in length <td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")