use strict;
my $str = '<html>
<tabel tags="gohere\'>
<tr>
<td>detects strings</td>
<td>
of a
length
</td>
</tr>
<tr>
<td>
and <b> ignores HTML </b>
<br />
formating
</td>
<td> this checks for string atleast 7 char in length <td>
</tr>
</table>
</html>';
my $regex = qr/((?![^<]*?>)\b[\w\h]{7,})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}