import Foundation
let pattern = #"((?![^<]*?>)\b[\w\h]{7,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<tabel tags="gohere'>
<tr>
<td>detects strings</td>
<td>
of a
length
</td>
</tr>
<tr>
<td>
and <b> ignores HTML </b>
<br />
formating
</td>
<td> this checks for string atleast 7 char in length <td>
</tr>
</table>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)